Data Replication 2
Results 1 to 3 of 3

Thread: Failed to bind datasource

  1. #1
    Haloo is offline Junior Member
    Join Date
    Jan 2008
    Posts
    2
    Rep Power
    0

    Failed to bind datasource

    Hi,

    Using the connection string:

    "Provider=AttunityConnect;Database=MYDATABASE;Bind ing=MYBINDING"

    I'm able to connect to the Enscribe database and run queries using it in a windows application. However, when I use the same thing with IIS(5.1), it doesn't work and throws following error :

    Error Message from Server :: [800D] ICommand::Execute: Failed to prepare the command. SQL = SELECT * FROM MYTABLE
    [800D] ICommandPrepare: Failed to prepare the command. SQL = SELECT * FROM MYTABLE [A00B] Failed to bind datasource 'sys' to datasource 'MYDATABASE' [A08D] The binding entry 'MYDATABASE' was not found.

    I have also tried to remove binding and put binding information directly in the connection string (UN,PW,Datasource,Port,Workspace,Database,Pooling) but nothing seems to work.

    Help Please!!

  2. #2
    Tony Mou is offline APAC Support Manager
    Join Date
    Sep 2006
    Location
    China
    Posts
    35
    Rep Power
    0
    Please make sure that IIS process have READ/WRITE right on AIS repository. NAVROOT/DEF/sys.*
    To Find Out more About Attunity Technology:
    Attunity
    or:
    Contact Us

  3. #3
    Haloo is offline Junior Member
    Join Date
    Jan 2008
    Posts
    2
    Rep Power
    0

    Thanks!!

    Thanks for the help. It works now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •