Get Data Moving 1
Results 1 to 3 of 3

Thread: Oracle connection not working with CDC, but works for full loads

  1. #1
    anuragbiswas is offline Junior Member
    Join Date
    Oct 2014
    Posts
    6
    Rep Power
    0

    Oracle connection not working with CDC, but works for full loads

    The same Oracle connection that works when a task is a full load, fails in a task with CDC. I am getting the below error. What is the reason for this?
    "OCI error 'ORA-12154: TNS:could not resolve the connect identifier specified'"

  2. #2
    stevenguyen is offline Senior Member
    Join Date
    May 2014
    Posts
    297
    Rep Power
    6
    Quote Originally Posted by anuragbiswas View Post
    The same Oracle connection that works when a task is a full load, fails in a task with CDC. I am getting the below error. What is the reason for this?
    "OCI error 'ORA-12154: TNS:could not resolve the connect identifier specified'"
    Hello Anura,

    What version of Oracle are you running as the source?

    What version of the Oracle client are your running on the Replicate server?

    from checking on the OCI error ORA-12154, this could be related to registry entry, please see the article below:

    https://social.msdn.microsoft.com/fo...or-encouneterd

    https://community.oracle.com/thread/905661?tstart=0

    oracle - PHP oci_connect() TNS:could not resolve the connect identifier (ORA-12154) - Stack Overflow

    http://www.attunity.com/forums/micro...olve-1369.html

  3. #3
    anuragbiswas is offline Junior Member
    Join Date
    Oct 2014
    Posts
    6
    Rep Power
    0
    Quote Originally Posted by stevenguyen View Post
    Hello Anura,

    What version of Oracle are you running as the source?

    What version of the Oracle client are your running on the Replicate server?

    from checking on the OCI error ORA-12154, this could be related to registry entry, please see the article below:

    https://social.msdn.microsoft.com/fo...or-encouneterd

    https://community.oracle.com/thread/905661?tstart=0

    oracle - PHP oci_connect() TNS:could not resolve the connect identifier (ORA-12154) - Stack Overflow

    http://www.attunity.com/forums/micro...olve-1369.html

    Attunity Replicate is on a Windows 7 64 bit machine. The Oracle DB and Oracle Client are also 64 bit and on the same machine.

    We were using the connection string as "(DESCRIPTION = (ADDRESS_LIST ... )". Once we changed the connection string to "host:port/service name" instead (as mentioned in the last link you provided) we could connect to Oracle for CDC tasks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •