Get Data Moving 1
Results 1 to 8 of 8

Thread: [123002] Failed to connect to Attunity CloudBeam AMI.

  1. #1
    ram
    ram is offline Junior Member
    Join Date
    Jan 2015
    Posts
    23
    Rep Power
    0

    [123002] Failed to connect to Attunity CloudBeam AMI.

    Hi,

    Am getting below error
    [123002] Failed to connect to Attunity CloudBeam AMI.
    please help soon.

  2. #2
    reza.khan is offline Junior Member
    Join Date
    Jun 2013
    Posts
    25
    Rep Power
    0
    Quote Originally Posted by ram View Post
    Hi,

    Am getting below error
    [123002] Failed to connect to Attunity CloudBeam AMI.
    please help soon.
    Hello Ram,

    Thank you for contacting technical support.

    Please provide more information about the issue by answering the following questions:

    1. Has this connection ever worked before or is this the first time your are connecting to this AMI.
    2. During what stage is this error occurring? Please attach a screenshot of the entire error message.

    Looking forward to your response.

    Thank you.

    Reza K

  3. #3
    rameshpachamuthu is offline Junior Member
    Join Date
    Mar 2015
    Posts
    19
    Rep Power
    0
    Hi,
    I am getting the same error. Do you have any resolution for this issue?
    I am getting this error as soon as I start the task to run. I used to run the task (from RDS Oracle to Redshift) using same same source and target. However all of a sudden I am not able to run this task. The full error from the log.

    00003148: 2015-04-06T23:37:32 [SERVER ]I: Task Server Log - test 1 (V4.0.5.29 WIN-248F6AQN79J Microsoft Windows 64-bit, PID: 2192) started at Mon Apr 06 23:37:32 2015 (logger.c:448)
    00003148: 2015-04-06T23:37:32 [INFRASTRUCTURE ]I: Product license was not found. (license.c:746)
    00003148: 2015-04-06T23:37:32 [SERVER ]I: Client session (ID 30534) allocated (dispatcher.c:237)
    00003148: 2015-04-06T23:37:32 [TASK_MANAGER ]I: Task 'test 1' running full load only in resume mode (replicationtask.c:728)
    00003148: 2015-04-06T23:37:32 [METADATA_MANAGER]I: ODBC additional properties = '(null)' (mysql_endpoint_imp.c:569)
    00003148: 2015-04-06T23:37:32 [METADATA_MANAGER]I: Connecting to MySQL through ODBC connection string: DRIVER={MySQL ODBC 5.2 Unicode Driver};SERVER=RDS_HOST;port=3306;UID=awsuser;PWD= ****;DB=;Option=74448896; (mysql_endpoint_imp.c:653)
    00003148: 2015-04-06T23:37:32 [METADATA_MANAGER]I: Going to connect to server REDSHIFT_HOST database dev (redshift_imp.c:726)
    00003148: 2015-04-06T23:37:32 [METADATA_MANAGER]I: Connected to server REDSHIFT_HOST database dev successfully. (redshift_imp.c:745)
    00003148: 2015-04-06T23:37:32 [UTILITIES ]I: The state is restored from file 'C:\Program Files\Attunity\Replicate\data\tasks\test 1/StateManager/ars_saved_state_000002.sts' saved at Mon, 06 Apr 2015 23:37:18 GMT (1428363438778600) (statemanager.c:1033)
    00002900: 2015-04-06T23:37:32 [TASK_MANAGER ]I: Creating threads for all components (replicationtask.c:1151)
    00002900: 2015-04-06T23:37:32 [TASK_MANAGER ]I: All stream components were initialized (replicationtask.c:1912)
    00002900: 2015-04-06T23:37:32 [TASK_MANAGER ]I: Starting subtask #1 (replicationtask_util.c:856)
    00002900: 2015-04-06T23:37:32 [TASK_MANAGER ]I: Threads for all components were created (replicationtask.c:1297)
    00002900: 2015-04-06T23:37:32 [TASK_MANAGER ]I: Task initialization completed successfully (replicationtask.c:2064)
    00002316: 2015-04-06T23:37:32 [SOURCE_UNLOAD ]I: ODBC additional properties = '(null)' (mysql_endpoint_imp.c:569)
    00002316: 2015-04-06T23:37:32 [SOURCE_UNLOAD ]I: Connecting to MySQL through ODBC connection string: DRIVER={MySQL ODBC 5.2 Unicode Driver};SERVER=RDS_HOST;port=3306;UID=awsuser;PWD= ****;DB=;Option=74448896; (mysql_endpoint_imp.c:653)
    00003428: 2015-04-06T23:37:32 [TARGET_LOAD ]I: Going to connect to server REDSHIFT_HOST database dev (redshift_imp.c:726)
    00003428: 2015-04-06T23:37:32 [TARGET_LOAD ]I: Connected to server REDSHIFT_HOST database dev successfully. (redshift_imp.c:745)
    00003428: 2015-04-06T23:37:32 [INFRASTRUCTURE ]E: Http request sent to <AMI_CLIENT> failed: got http status 500 Server Error Http request sent failed. (at_http_client.c:737)
    00003428: 2015-04-06T23:37:32 [INFRASTRUCTURE ]E: failed to encrypt the link for url </transfer/cifta_server> (second encryption step failed) Failed to encrypt csdk link: pre-encryption step failed (at_csdk.c:889)
    00003428: 2015-04-06T23:37:32 [INFRASTRUCTURE ]E: Post connect callback failed. (at_http_client.c:903)
    00003428: 2015-04-06T23:37:32 [INFRASTRUCTURE ]E: - [123002] Failed to connect to Attunity CloudBeam AMI. (ar_cifta.c:514)
    00003428: 2015-04-06T23:37:32 [INFRASTRUCTURE ]E: -Http request sent to <AMI_CLIENT> failed: got http status 500 Server Error [123002] Failed to connect to Attunity CloudBeam AMI. (ar_cifta.c:514)
    00003428: 2015-04-06T23:37:32 [INFRASTRUCTURE ]E: -Http request sent to <AMI_CLIENT> failed: got http status 500 Server Error; failed to encrypt the link for url </transfer/cifta_server> (second encryption step failed); Post connect callback failed. [1000310] [123002] Failed to connect to Attunity CloudBeam AMI. (ar_cifta.c:514)
    00003428: 2015-04-06T23:37:32 [INFRASTRUCTURE ]E: failed to connect [123002] Failed to connect to Attunity CloudBeam AMI. (ar_cifta.c:514)
    00003428: 2015-04-06T23:37:32 [TARGET_LOAD ]E: Failed to start AMI Client [123002] Failed to connect to Attunity CloudBeam AMI. (redshift_imp.c:903)
    00003428: 2015-04-06T23:37:32 [TASK_MANAGER ]E: Failed while preparing stream component 'st_1_redshift tgt'. [123002] Failed to connect to Attunity CloudBeam AMI. (subtask.c:788)
    00003428: 2015-04-06T23:37:32 [TASK_MANAGER ]E: Cannot initialize subtask [123002] Failed to connect to Attunity CloudBeam AMI. (subtask.c:1193)
    00003428: 2015-04-06T23:37:32 [TARGET_LOAD ]E: Stream component 'st_1_redshift tgt' terminated [123002] Failed to connect to Attunity CloudBeam AMI. (subtask.c:1450)
    00002900: 2015-04-06T23:37:32 [TASK_MANAGER ]I: Subtask #1 ended (replicationtask_util.c:919)
    00002900: 2015-04-06T23:37:32 [TASK_MANAGER ]E: Task error notification received from subtask 1, thread 1 [123002] Failed to connect to Attunity CloudBeam AMI. (replicationtask.c:1752)
    00002900: 2015-04-06T23:37:32 [TASK_MANAGER ]I: Task 'test 1' encountered a recoverable error (repository.c:4005)

    Thanks
    RP

  4. #4
    stevenguyen is offline Senior Member
    Join Date
    May 2014
    Posts
    299
    Rep Power
    6
    Hello rameshpachamuthu,

    1. I assume that you have all the ports configure correctly according to our guide:

    Quick Start Guide: Attunity CloudBeam for Amazon Redshift | Attunity

    Connectivity & Ports: Firewall ports 5746 (Attunity CloudBeam) and 5439 (Amazon Redshift Cluster), opened one-way / outbound.

    2. Make sure that your Target Redshift DB definition within Replicate does not have any Space.

    3. Could you check on your Attunity Cloudbeam AMI server, under Add/Remove Programs to see, What version is the Attunity Maestro Agent installed?
    if the Attunity Maestro Agent is not 1.1.0.36, then it needs to be updated to version 1.1.0.36.

    To upgrade the Cloudbeam Agent:
    1. Stop any current running tasks, from the Replicate Console.
    2. download the new Cloudbeam Agent to the Attumity AMI server.
    3. Stop the Attunity Maestro Agent service.
    4. Run the upgrade on both file, one at a time.
    5. Restart the Attunity Maestro Agent service.
    6. Back on the Replicate server, resume your task or Reload your task.

    ftp://ftp.attunity.com/public/Patch/...n_1.1.0.36.exe
    ftp://ftp.attunity.com/public/Patch/...n_1.1.0.36.exe

    Thanks,
    Steve

  5. #5
    stevenguyen is offline Senior Member
    Join Date
    May 2014
    Posts
    299
    Rep Power
    6
    customer post others forums:

    "Thanks Steve. Following your suggestion of updating the components fixed the issue. Really appreciate for assisting me here.

    Regards,
    Ramesh"

  6. #6
    kad
    kad is offline Junior Member
    Join Date
    Apr 2015
    Posts
    8
    Rep Power
    0
    Quote Originally Posted by stevenguyen View Post
    customer post others forums:

    "Thanks Steve. Following your suggestion of updating the components fixed the issue. Really appreciate for assisting me here.

    Regards,
    Ramesh"
    Hi Steve, I'm still having this problem where my replicate server cannot connect to my AMI anymore. Is there a new release after 1.1.0.36? Is there a page to download the latest agent?


    Code:
    
    00003876: 2015-05-26T17:16:29 [INFRASTRUCTURE  ]E:  Http request sent to <...> failed: got http status 500 Server Error Http request sent failed. (at_http_client.c:737)
    00003876: 2015-05-26T17:16:29 [INFRASTRUCTURE  ]E:  failed to encrypt the link for url </transfer/cifta_server> (second encryption step failed) Failed to encrypt csdk link: pre-encryption step failed (at_csdk.c:889)
    00003876: 2015-05-26T17:16:29 [INFRASTRUCTURE  ]E:   Post connect callback failed. (at_http_client.c:903)
    00003876: 2015-05-26T17:16:29 [INFRASTRUCTURE  ]E:   - [123002] Failed to connect to Attunity CloudBeam AMI. (ar_cifta.c:514)
    00003876: 2015-05-26T17:16:29 [INFRASTRUCTURE  ]E:   -Http request sent to <...> failed: got http status 500 Server Error [123002] Failed to connect to Attunity CloudBeam AMI. (ar_cifta.c:514)
    00003876: 2015-05-26T17:16:29 [INFRASTRUCTURE  ]E:   -Http request sent to <...> failed: got http status 500 Server Error; failed to encrypt the link for url </transfer/cifta_server> (second encryption step failed); Post connect callback failed. [1000310] [123002] Failed to connect to Attunity CloudBeam AMI. (ar_cifta.c:514)
    00003876: 2015-05-26T17:16:29 [INFRASTRUCTURE  ]E:  failed to connect [123002] Failed to connect to Attunity CloudBeam AMI. (ar_cifta.c:514)
    00003876: 2015-05-26T17:16:29 [TARGET_APPLY    ]E:  Failed to start AMI Client [123002] Failed to connect to Attunity CloudBeam AMI. (redshift_imp.c:903)
    00003876: 2015-05-26T17:16:29 [TASK_MANAGER    ]E:  Failed while preparing stream component 'st_0_amazon redshift'. [123002] Failed to connect to Attunity CloudBeam AMI. (subtask.c:788)
    00003876: 2015-05-26T17:16:29 [TASK_MANAGER    ]E:  Cannot initialize subtask [123002] Failed to connect to Attunity CloudBeam AMI. (subtask.c:1193)
    00003876: 2015-05-26T17:16:29 [TARGET_APPLY    ]E:  Stream component 'st_0_amazon redshift' terminated [123002] Failed to connect to Attunity CloudBeam AMI. (subtask.c:1450)

  7. #7
    stevenguyen is offline Senior Member
    Join Date
    May 2014
    Posts
    299
    Rep Power
    6
    Notes if all of the above fail. The problem could be simple as the Database definition for your source and target having a space.

    for example, my source database definition could be "SQL Server" this would cause issue. you would need to have it "SQLServer"

  8. #8
    stevenguyen is offline Senior Member
    Join Date
    May 2014
    Posts
    299
    Rep Power
    6
    Quote Originally Posted by stevenguyen View Post
    Hello rameshpachamuthu,

    1. I assume that you have all the ports configure correctly according to our guide:

    Quick Start Guide: Attunity CloudBeam for Amazon Redshift | Attunity

    Connectivity & Ports: Firewall ports 5746 (Attunity CloudBeam) and 5439 (Amazon Redshift Cluster), opened one-way / outbound.

    2. Make sure that your Target Redshift DB definition within Replicate does not have any Space.

    3. Could you check on your Attunity Cloudbeam AMI server, under Add/Remove Programs to see, What version is the Attunity Maestro Agent installed?
    if the Attunity Maestro Agent is not 1.1.0.36, then it needs to be updated to version 1.1.0.36.

    To upgrade the Cloudbeam Agent:
    1. Stop any current running tasks, from the Replicate Console.
    2. download the new Cloudbeam Agent to the Attumity AMI server.
    3. Stop the Attunity Maestro Agent service.
    4. Run the upgrade on both file, one at a time.
    5. Restart the Attunity Maestro Agent service.
    6. Back on the Replicate server, resume your task or Reload your task.

    ftp://ftp.attunity.com/public/Patch/...n_1.1.0.36.exe
    ftp://ftp.attunity.com/public/Patch/...n_1.1.0.36.exe

    Thanks,
    Steve

    Note for Replicate users with version 4.8 and 4.9 It is recommended that you are running the latest Attunity Cloudbeam from Amazon Market place.

    The Attunity Cloudbeam agent on the new Attunity Cloudbeam are version 4.0.8.xx not 1.1.xx anymore.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •