Data Replication 2
Results 1 to 2 of 2

Thread: Missing column values when using Attunity Oracle Connector?

  1. #1
    douglas is offline Junior Member
    Join Date
    Oct 2013
    Posts
    2
    Rep Power
    0

    Missing column values when using Attunity Oracle Connector?

    Hello...
    I have an SSIS Package (vs2008) and I am using the Attunity Oracle source component to query and pull data from Oracle to Sql Server (sql 2012).

    I have a query that runs in Oracle Sql Developer and mostly works in my ssis package. The problem, I just discovered, is that some of the columns that have data in my query when run in Sql Developer are NULL when the data ends up in my Sql Server table. The column is a varchar2(10 byte) data type in Oracle and in the sql server table it is a varchar(10). i even tried increasing the length of the column to see if that would resolve the issue...but it did not.

    Now, I am very concerned that I have been missing data in other tables/columns for a while.

    Just wondering if anyone has experienced this issue and has any thoughts or suggestions.

    thanks

  2. #2
    douglas is offline Junior Member
    Join Date
    Oct 2013
    Posts
    2
    Rep Power
    0
    Hi All
    I figured out the issue...it was the connection. The package was supposed to be connecting to a QA server, but a while back the server connection was changed to a Dev server and not all of the data columns were being populated. Once I realized this issue and switched to the original server, the columns were populated as expected.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •