Load Ingest Data
Results 1 to 2 of 2

Thread: SQL against RMS file mappings on VMS

  1. #1
    jobrien is offline Junior Member
    Join Date
    Aug 2009
    Rep Power

    SQL against RMS file mappings on VMS

    Hi there,

    when executing queries against RMS (using nav_util/studio etc) we are using a VMS logical name as the datasource name which is resolved on the server.

    I have found that if in error that datasource is not set, then the default action is for Attunity to return an empty set for a query, and to write to a file named "." in the server accounts home directory when doing an insert/update.

    Is there any way to enforce a data source and for attunity to raise an exception rather than the default behavior described above?

    obviously, we can do a hack by creating a file named "." with privilieges that will cause attunity to error - but i regard this as a hack.



  2. #2
    Join Date
    Sep 2006
    Rep Power
    Hi Jim,

    The default action for non-existing source data files is indeed to return an empty result set and this is by design as it is equated with the case of a SQL table that exists but has no data. Experience shows that this is what most people and applications would use (unlike the case where you drop the SQL table definition for the RMS file, in which case you would get an error).

    I cannot say the same for the other case of writing a '.' file though with the big variety of options one gets with OpenVMS logical names, it is hard to contain all options. If creating a dummy .; file with proper privileges solves the issue for you then I'd say- go for it. You do not need to do it by user though, you can use a DCL script NAVROOT:[BIN]SITE_NAV_LOGIN.COM to look for this file and to create it if does not exist, setting its privileges as needed).

    By Dror Harari

    To Find Out more About Attunity Technology:
    Contact Us

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts