IN case you have a lenght query that you would like to run in the Studio Query tool and you get an TimeOut, increase the following paramater

Use Studio- Preferences- ADVANCED Interaction TimeOut