Results 1 to 6 of 6

Thread: Error installing Microsoft connector for Oracle version 2.0

  1. #1
    cscdba is offline Junior Member
    Join Date
    Nov 2012
    Posts
    4
    Rep Power
    0

    Error installing Microsoft connector for Oracle version 2.0

    I am getting an error while installing this adapter. While installing the AttunitySSISOraAdaptersSetupX64.msi the installer aborts saying "Microsoft SQL Server is not installed". "The English version of the connector will be installed". It then goes on to error out while registering various dlls.

    I have made sure I have .NET 4.5/proper version of IIS/proper version of Visuall C++ installed.

    Can you please tell me why if this happening? This driver is so much better and faster than OLEDB that I cannot ignore using it.

    Thanks!

  2. #2
    Gadi.Farhat is offline Development Manager
    Join Date
    Mar 2009
    Posts
    255
    Rep Power
    11
    Some questions:
    • What version of the connector are you trying to install?
    • Do you have SSIS installed on the machine?
    • Do you have SQL Server installed on the machine?
    • What is the OS?
    • Do you have the x64/x86 C++ redistributable installed?



    Regards,

    Gadi
    To Find Out more About Attunity Technology:
    Attunity
    or:
    Contact Us

  3. #3
    cscdba is offline Junior Member
    Join Date
    Nov 2012
    Posts
    4
    Rep Power
    0
    Thanks for your fast response.

    Some questions:


    • What version of the connector are you trying to install?

    I am trying to install version 2.0. since I have some major data mapping issues from Oracle to SQL Server in version 1.0. I am hoping they have been resolved in version 2.0.

    • Do you have SSIS installed on the machine?

    Yes SSIS is installed in this machine.

    • Do you have SQL Server installed on the machine?

    Yes - SQl Server 2008 SP2

    • What is the OS?

    Windows Server 2008 R2 Standard

    • Do you have the x64/x86 C++ redistributable installed?

    Yes.

  4. #4
    Gadi.Farhat is offline Development Manager
    Join Date
    Mar 2009
    Posts
    255
    Rep Power
    11
    Hi,

    Version 2.0 of the connecotor, supports SSIS 2012 only. The latest version that support SSIS 2008 / 2008R2 is version 1.2 of the connector.


    Regards,

    Gadi
    To Find Out more About Attunity Technology:
    Attunity
    or:
    Contact Us

  5. #5
    cscdba is offline Junior Member
    Join Date
    Nov 2012
    Posts
    4
    Rep Power
    0
    Very cool! Thank you so much for your help!

    I love this driver. This is 30 times as fast as MS OLEDB driver for Oracle.

    Thanks again! All my packages are working like a charm!!!

  6. #6
    cscdba is offline Junior Member
    Join Date
    Nov 2012
    Posts
    4
    Rep Power
    0
    Could I ask you one more question since I have this thread open? :o

    How do I get an entire Oracle schema into SQL Server? Do I need to set up individual data sources for each and every table from Oracle--> SQL Server or is there is a faster way to do that?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •