I am using Attunity Oracle drivers to connect to Oracle Database on a remote server to retrieve data and dump into Excel File. Everything works fine in Visual Studio BIDS. From VS I can connect directly to remote Oracle server and retrieve the data.
But when i deploy this ETL to my production server (64 Bit Windows Server 2008 & SQL Server 2012), ETL is always get stuck at Execution phase. After running for some time (20-30 mins), it gives followingwarning & still keeps running without giving any errors -

[SSIS.Pipeline] Information: The buffer manager detected that the system was low on virtual memory, but was unable to swap out any buffers.0 buffers were considered and0 were locked.
Either not enough memory is available to the pipeline because not enough is installed, other processes are using it,or too many buffers are locked.



Some more info -

  1. I have checked server memory, only 3GB is in use out of total 12GB.
  2. I have already set SQL server to use max 8GB.
  3. I am using SQL Server Agent job to run the ETL periodically every 15 mins.
  4. I have tried stopping all other ETLs on the server and tried running this ETL through Execute Package Utility but still the result is same.
  5. I am using a date range in Oracle Query to retrieve the data, when the query for a particular date range does not return any data, ETL execution is always successful !!.

Any pointers/suggestion ??