DESCRIPTION

When working with Turkish locale, the C toupper function turns 'i' into '0' and the tolower function turns 'I' into '1'. This causes errors when loading the Attunity environment.

Here are some of the errors you would see in the log file:

[A088] Installed license is not valid.

Environment File Warning: Too small value for 'HASH_MAX_DISK_SPACE'- 0; Value enlarged to 20

Environment File Warning: Too small value for 'HASH_BUFFER_SIZE'- 0; Value enlarged to 10000

Environment File Warning: Too small value for 'COM_CACHE_BUFFER_SIZE'- 0; Value enlarged to 10000

Environment File Warning: Too small value for 'TOKEN_SIZE' - 0; Value enlarged to - 64

Environment File Warning: Too small value for 'DSM_MAX_BUFFER_SIZE'- 0; Value enlarged to 20000

Environment File Warning: Invalid value for 'SEMI_JOIN_IN_VALUES_FACTOR' - 0; Value reset to default - 10

Environment File Warning: Invalid value for 'QP_MAX_COLS_IN_PARS' - 0; Value reset to default - 500

Environment File Warning: Invalid value for 'OLEDB_MAX_HROWS' - 0; Value reset to default - 100

Environment File Warning: Invalid value for 'SEGMENTED_DB_MAX_THREADS' - 0; Value reset to default - 3

Environment File Warning: Too small value for 'QP_MAX_SQL_CACHE'- 0; Value enlarged to 3

Error: no conversion from codepage 'WINDOWS-1252' to codepage 'ASCII' - replacing text with '?' marks
[E003] Corrupted codepage file or mismatching language setting
[C077] Could not find symbol 'register_tur' in dynamic library
[A0BA] SYNTAX FILE ERROR: The entry Identifier_quote_char given in section OLESQL_JOLT in the syntax file is incorrect. Please check the syntax.
[A0BA] SYNTAX FILE ERROR: The entry like given in section OLESQL_JOLT in the syntax file is incorrect. Please check the syntax.
[A0BD] SYNTAX FILE ERROR: There are errors in section OLESQL_JOLT definiton. This section is ignored !!!
[A0BA] SYNTAX FILE ERROR: The entry position given in section SQLMX_SYNTAX in the syntax file is incorrect. Please check the syntax.
[A0BD] SYNTAX FILE ERROR: There are errors in section SQLMX_SYNTAX definiton. This section is ignored !!!
[A0BC] There are errors in the syntax file. Please check nav.syn and the messages in the log file.
Connecting to 172.25.2.30:39684:tcp:13608
[37000] [9023]Sql text too long. Try to: 1.Increase 'QP_MAX_COLS_IN_PARS' in the env file (in case the sql text consists of many columns).
2. Shorten the sql text.
SOLUTION

The solution is to modify the DSConfig.txt at the Server side of the Data Integrator (in Unix) and set the AL_Engine as follows:

[Locales]
AL_Engine=eng_us.iso-8859-#
Where the casing must be exact and the # can be 1 to 15 as needed.

For example, to use the Latin-5 or Turkish (iso-8859-9), set the AL_Engine as follows:

[Locales]
AL_Engine=eng_us.iso-8859-9