Load Ingest Data
Results 1 to 1 of 1

Thread: Linked Servers: Adabas and SQLServer

  1. #1
    Adeeb Mass'ad is offline Support Manager
    Join Date
    Aug 2006
    Location
    Jaffa of Nazareth
    Posts
    169
    Rep Power
    14

    Linked Servers: Adabas and SQLServer

    DESCRIPTION

    The user is getting an “Unspecified error“ working with the Linked Server (DQP) SQLserver 2000 and Attunity Server ADABAS driver.

    SCENARIO

    The user has created the followings:-
    1. Configured an Attunity Server ADD-ADABAS DataSource (called ADDADA).
    2. An ODBC DataSource which used the Attunity Server ODBC driver and points to the ADDADA (called ATTDSN).
    3. Created an ODBC Linked Server.
    • Provider Name: “Microsoft OLEDB Provider for ODBC Drivers“.
    • Data source: ATTDSN (Created in Step 1).
    4. Invoked “Query Analyser“ of SQLServer.
    5. Executed a SELECT statement against the newly created Linked Server, for example:
    SELECT * FROM ATTDSN.ADDADA.“public“.employees
    The following error was displayed in the Query Analyser:
    Server: Msg 7399, Level 16, State 1, Line 1
    OLE DB provider 'MSDASQL' reported an error.
    [OLE/DB provider returned message: Unspecified error]
    OLE DB error trace [OLE/DB Provider 'MSDASQL' IDBSchemaRowset::GetRowset returned 0x80004005: ].
    In the Connect log file, you can locate the following error:
    (0) nvRETURN (P:\Src\DRV\DRV_IROW.C 228): -2204
    (0) [A016] GetRows on RowCursor failed on table name 'SP_TABLES'.
    DIAGNOSIS
    1. Linked Servers are created as “Allow In Process“ by default. This means, that it shares the SQLServer resources.

    2. We found that there is a problem, running the Adabas DLLs at the same process with SQLServer. This happened because the user is running the ADABAS Server (on Windows) v3.11.
    On another machine running “Entire Network“ client, the scenario worked.

    3. To test this behaviour we created a remote bindng, and ran the scenario in Client/Server mode, which worked.
    SOLUTION

    The solution is to run the Linked Server “Out of Process”, this will prevent the DLLs from interfering with each other.

    To run the Linked Server in “Out of Process“ mode:
    1. Create a new Linked Server (or delete and recreate).
    2. Click on the “Provider Options“.
    3. Uncheck the “Allow InProcess“ checkbox.
    Last edited by Costi Zaboura; 06-19-2008 at 02:26 AM.
    To Find Out more About Attunity Technology:
    Attunity
    or:
    Contact Us

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •