DESCRIPTION

We have a prospect want to use our ODBC API on linux to access Oracle9 . We are trying to setup an simulate environment. But we found it failed in installation.

WE found the problem happened on nav_util import nav-env.xml template. and there is no repository generated ,I mean there is no sys*.* file.

And I also tried to execute "nav_util" without any parameter after execuet nav_login.sh,even there is no sys*.* file ,it report "segment failure." ,the same error message as it is displayed during installation.

The Linux we used is Redhat Fedora 2.6.11-1.1369_FC4.


SOLUTION

The problem is fixed:

If we did
[root@Linux lib]# export LD_PRELOAD=/usr/ac4620/navroot/lib/nvdb_disam.so
[root@Linux lib]# nav_util

It will report:

nav_util: error while loading shared libraries: /usr/ac4620/navroot/lib/nvdb_disam.so: cannot restore segment prot after reloc: Permission denied

An explanation as to why this error occurs can be found here:
http://www.rsinc.com/services/techtip.asp?ttid=3092

Summation:
Newer Linux distributions have enabled new kernel security extensions from the SELinux project at the NSA. These extensions allow finer-grained control over system security. However, SELinux also changes some default system behaviors, such as shared library loading, that can be problematic to third party programs.

If you receive the error message "cannot restore segment prot after reloc: Permission denied" when launching IDL, then your SELinux configuration is preventing launch.

To rectify this issue, you can either:

Change the default security context

"chcon -t texrel_shlib_t $NAVROOT/lib/*.so"

Disabling SELinux altogether by setting the line

SELINUX=disabled

in your /etc/sysconfig/selinux file.